Welcome Guest! To enable all features please Login or Register.
Go to last post Go to first unread
Lars Holmquist  
#1 Posted : Friday, July 27, 2012 11:29:08 AM(UTC)
Lars Holmquist
Rank: Member

Groups: extranet\Forum
Joined: 9/7/2011(UTC)
Posts: 8


I am currently building a report that should consist of several pages based on 2 dimensions (departments, working areas). When I add two "source data" dimensions to the report in the sequence of "Department, working area" the result is a report with a page for all working areas (including empty ones). I only want report pages for the subset of the department and working area dimensions.

Let me explain the details.

The department dimension is a list in this fashion: 1, 2, 3, 4, 5, 6 etc.
The working areas is a dimension in a similar manner: A, B, C, D, E, F etc.

We have roughly 850 working areas and 100 departments. Some working areas are utilized in many departments - some are exclusively used in one department.

Report set:
The report set consists of two reports.

1st report: is an overview of one department listing all relevant working areas with one measure compared over this/previous year.
2nd report: a detailed page pr. working area (using department and working areas as source data) that illustrates the distribution over 12 months.

The first report works fine. The second does not. For some reason I get 850 pages (one for each of the working areas) no matter what department I choose. For many departments there are in average 20 utilized working areas, so the remaining 830 produces blank pages.

I assume that I somehow need to define the relationship between the two dimensions to only retrieve the subset. But how.. ?
#2 Posted : Wednesday, August 8, 2012 1:39:55 PM(UTC)
Rank: Administration

Groups: extranet\Forum
Joined: 4/7/2011(UTC)
Posts: 323

Hi Lars,

Normally your report should not come up with empty results. This is an unexpected behaviour. Unless ... your database connection generally has been set up to include empty query results. (Can be verified from TARGIT Management Studio / Connections.)

If this is not the problem, I might be able to investigate further if you posted a screenshot of the report in define mode.
I work as an employee with TARGIT A/S. Any statement made by me in this forum represents my own opinion and state of mind, and is not necessarily related to or representative of TARGIT A/S.

UserPostedImage Ole Dyring
Users browsing this topic
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.