en
Welcome Guest! To enable all features please Login or Register.
Options
Go to last post Go to first unread
Eric Maibach  
#1 Posted : Friday, March 29, 2013 2:58:58 PM(UTC)
Eric Maibach
Rank: Advanced Member

Groups: extranet\Forum
Joined: 11/28/2012(UTC)
Posts: 12

We are currently doing testing for upgrading from Targit 2K11 build 4968 to build 5293. We are seeing issues with fiscal calendar YTD comparisons on reports that we are upgrading from 4968 to 5293. For example we have a report that has a comparison of YTD for the current year, and YTD of the previous year. It works correctly in build 4968. When we bring it to build 5293 the previous year YTD value is correct, however the current year YTD will show only show January to March and our fiscal year begins in October.

If I create a new report in build 5293 and create a new YTD comparison then it functions correctly. If you use the Targit client to look at the two reports and compare how the YTD criteria are configured they are identical. However if I open the Targit report files in a text editor they look completely different.

Here is what the YTD criteria looks like from the report that was brought over from build 4968:

<criteria build="4968">
<database name="database">
<hierarchy name="Delivery Date.Fiscal Date" cubeorigin="Prod">
<mustbe type="inrange">
<daterange excludefirst="false" excludelast="false">
<datemember>
<year relative="0"/>
</datemember>
<datemember>
<year relative="0"/>
<month relative="0"/>
</datemember>
</daterange>
</mustbe>
</hierarchy>
</database>
</criteria>

Here is what the YTD criteria looks like from the report that was created in build 5293:

<criteria build="5293">
<criterium kind="dynamictime">
<metadata database="database" cube="Prod" dimension="Delivery Date" hierarchy="Fiscal Date"/>
<operator kind="inrange">
<left closed="true">
<applyto level="year"/>
<steps/>
</left>
<right closed="true">
<applyto level="month"/>
<steps/>
</right>
</operator>
</criterium>
</criteria>

What do we need to do in order to get our existing reports to upgrade to build 5293 correctly?

Thank You
David L. Bojsen  
#2 Posted : Sunday, March 31, 2013 7:42:10 PM(UTC)
David L. Bojsen
Rank: Advanced Member

Groups: extranet\Forum
Joined: 3/21/2013(UTC)
Posts: 19

ericmaibach@dairyenterprisesinc.com wrote:
...

What do we need to do in order to get our existing reports to upgrade to build 5293 correctly?

Thank You


Hi Eric

Have you created an issue in the TARGIT Support System?
I would go about it that way. I doubt that another (non-TARGIT-employee) user can help you with this.

If you do get help that way - please post an update with the steps taken, so that us others can learn from it.

I know this isn't much help, but hope you resolve it with the support staff from TARGIT.
Venlig hilsen / Best regards

David L. Bojsen
Kapacity A/S

UserPostedImage

Any statement made by me in this forum represents my own opinion and state of mind, and is not necessarily related to or representative of my employer Kapacity A/S.
Users browsing this topic
Anonymous
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Notification

Icon
Error